Memgraph installed but not detected by MemgraphLab

Docker says that it is running. I don’t know what to do.

Went for cloud. Nevermind!

Hi @EnjoysMath :slight_smile: You first started the Memgraph Platform image which includes:

  • MemgraphDB - the database that holds your data
  • Memgraph Lab - visual user interface for running queries and visualizing graph data
  • mgconsole - command-line interface for running queries
  • MAGE - graph algorithms and modules library

Not sure why you then closed the connection and tried to start the Memgraph MAGE image, which consists of Memgraph and MAGE, without Memgraph Lab. But, when you tried to do it, you could see that the port was already allocated, and that meant you did not close the previous connection properly. In order to see this working correctly, please run:

docker ps

See the ID of the running containers. Run:

docker stop <container_id>

for each of the running containers.

In the end, if you want to run the Memgraph Platform image, that is, have Memgraph Lab in the browser, it is enough to run the Memgraph Platform image and leave it running.

1 Like